android10系统手机报错:does not meet the requirements to access device identifiers.

  • 时间:
  • 浏览:
  • 来源:互联网

今天安卓打包的apk在android10系统的设备上安装后刚点应用就闪退,通过Android studio连接设备查看调试信息发现如下报错:


AndroidRuntime: FATAL EXCEPTION: main
    Process: com.longkoo.djmajiang, PID: 9277
    java.lang.SecurityException: getSubscriberId: The user 10268 does not meet the requirements to access device identifiers.
        at android.os.Parcel.createException(Parcel.java:2071)
        at android.os.Parcel.readException(Parcel.java:2039)
        at android.os.Parcel.readException(Parcel.java:1987)
        at com.android.internal.telephony.IPhoneSubInfo$Stub$Proxy.getSubscriberIdForSubscriber(IPhoneSubInfo.java:1066)
        at android.telephony.TelephonyManager.getSubscriberId(TelephonyManager.java:3716)
        at android.telephony.TelephonyManager.getSubscriberId(TelephonyManager.java:3680)
        at com.longkoo.djmajiang.AppActivity.GetSubscriber(AppActivity.java:1411)
        at com.longkoo.djmajiang.AppActivity.startReadyGame(AppActivity.java:222)

从https://developer.android.google.cn/training/articles/user-data-ids文档中查看到:

避免使用硬件标识符。 在大多数用例中,您可以避免使用硬件标识符,例如 SSAID (Android ID) 和 IMEI,而不会限制所需的功能。

自 Android 10(API 级别 29)起,您的应用必须是设备或个人资料所有者应用,具有特殊运营商许可,或具有 READ_PRIVILEGED_PHONE_STATE 特权,才能访问不可重置的设备标识符。

这次打包我把targetSdkVersion设置成了29,然后用户权限里开启了READ_PRIVILEGED_PHONE_STATE,这个权限在 API 级别 29不能用了,所以我把targetSdkVersion改成低于29的值,例如我这边把targetSdkVersion改成了28就没有问题了。

本文链接http://www.hatan.cn/news/show-24683.html